[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: BoCon - when ? <!-- s/Bo/Bi/ -->
- To: Development Discussions <developer at arabeyes dot org>
- Subject: Re: BoCon - when ? <!-- s/Bo/Bi/ -->
- From: Behdad Esfahbod <behdad at cs dot toronto dot edu>
- Date: Mon, 29 Mar 2004 01:18:14 -0500
On Mon, 29 Mar 2004, Mohammed Elzubeir wrote:
> I recommend instead of having bicon and abicon, having bicon.bin and
> bicon respectively. I think that would help settle the confusion (and
> have seen it done by various other projects).
Well, I'm thinking something different: bicon is something that
almost works in all terminals, while abicon is console specific.
Moreover, (Alkarouri:) we should deliver bjoining_vu and
bconsole_vu too. They are extremely useful. The are cat-like
utilities to read Arabic in say gnome-terminal. BTW, they need
a better name. Perhaps not for this release. There are also
bconsole/vuconsole and bconsole/edconsole that need to be
> I personally am not a big fan of the 'abicon' -- it certainly threw me
Well, bicon is supposed to be a library for doing Arabic in
console. I mean, other programs are welcome to use the joining
stuff in bicon as a library. I'm not sure about the names, but
better we fix the names from the first release. Maybe "bicontty"
is a good name for "abicon", or "bycon" ;).
> Also, as far as the keymaps installing in places where specific distro's
> dictate -- let me tell ya, it will be a nightmare. I know, I had to deal
> with that with Akka.
> My recommendation is to leave that up to package creators.. or have the
> script 'detect/ask' what distro it is and selectively install based on
> that. Otherwise, every other distro seems to think different locations
> are more suitable for keymaps.
I only meant to do that in a portable way. Perhaps we can leave
it for now, but adding configure parameters for them is what I
see a clean solution. Guess there are parameters for that
already. RPM invokes ./configure with a myriad of parameters. I
will check later, no stopper for now.
> Mohammed Elzubeir