[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: BoCon - when ? <!-- s/Bo/Bi/ -->
- To: Development Discussions <developer at arabeyes dot org>
- Subject: Re: BoCon - when ? <!-- s/Bo/Bi/ -->
- From: Muhammad Alkarouri <malkarouri at yahoo dot co dot uk>
- Date: Mon, 29 Mar 2004 18:48:59 +0100
On ن, 2004-03-29 at 07:18, Behdad Esfahbod wrote:
> On Mon, 29 Mar 2004, Mohammed Elzubeir wrote:
> > I recommend instead of having bicon and abicon, having bicon.bin and
> > bicon respectively. I think that would help settle the confusion (and
> > have seen it done by various other projects).
> Well, I'm thinking something different: bicon is something that
> almost works in all terminals, while abicon is console specific.
Second that; bicon _will_ be used and also abicon, so I don't like the
> Moreover, (Alkarouri:) we should deliver bjoining_vu and
> bconsole_vu too. They are extremely useful. The are cat-like
> utilities to read Arabic in say gnome-terminal. BTW, they need
> a better name. Perhaps not for this release. There are also
> bconsole/vuconsole and bconsole/edconsole that need to be
The utilities are already compiled; we need just to change the noinst
and a little tweaking. We need to revise the scripts.
I don't like to release them with a temporary name, though. Any
> > I personally am not a big fan of the 'abicon' -- it certainly threw me
> > off.
> Well, bicon is supposed to be a library for doing Arabic in
> console. I mean, other programs are welcome to use the joining
> stuff in bicon as a library. I'm not sure about the names, but
> better we fix the names from the first release. Maybe "bicontty"
> is a good name for "abicon", or "bycon" ;).
I am not sure about the 'bicontty' name; it gives me a feeling of
agetty/mingetty/etc. Is it a full replacement for them?
I would suggest, in that order: bicondo, biconsole, bcon, bycon.
As an aside, I will remove the bin/bicon script. Any comments?
> > Also, as far as the keymaps installing in places where specific distro's
> > dictate -- let me tell ya, it will be a nightmare. I know, I had to deal
> > with that with Akka.
> > My recommendation is to leave that up to package creators.. or have the
> > script 'detect/ask' what distro it is and selectively install based on
> > that. Otherwise, every other distro seems to think different locations
> > are more suitable for keymaps.
> I only meant to do that in a portable way. Perhaps we can leave
> it for now, but adding configure parameters for them is what I
> see a clean solution. Guess there are parameters for that
> already. RPM invokes ./configure with a myriad of parameters. I
> will check later, no stopper for now.
Leave this for now. I think the proper location should be specified by
package creators, till keymaps and fonts find their way upstream.
> > Regards
> > Mohammed Elzubeir
> Developer mailing list
> Developer at arabeyes dot org