[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

qtquran segmentation fault on Red Hat 9

Assalam `alaykum

I've compiled qtquran-0.041 successfully by applying Mohammed Sameer's patch to enable it to compile using gcc 3.2.2.

However, when I run the application, I am getting a segmentation fault. Details of the error (gdb output), as well as about my system are in the attachment file.


Abu Bakar Al-Idrus
Here is the output when I run from gdb:


[abu at alidrus src]$ gdb ./qtquran

GNU gdb Red Hat Linux (5.3post-0.20021129.18rh)

Copyright 2003 Free Software Foundation, Inc.

GDB is free software, covered by the GNU General Public License, and you are

welcome to change it and/or distribute copies of it under certain conditions.

Type "show copying" to see the conditions.

There is absolutely no warranty for GDB.  Type "show warranty" for details.

This GDB was configured as "i386-redhat-linux-gnu"...

(gdb) run

Starting program: /home/abu/RPM/BUILD/qtquran-0.041/src/qtquran

[New Thread 1085113152 (LWP 17953)]

Program received signal SIGSEGV, Segmentation fault.

[Switching to Thread 1085113152 (LWP 17953)]

0x080585e5 in QuranApp (this=0x80fbee8) at qtquran.cpp:292

292             btnStop->setEnabled(1);


Details of the system I am running:


Pentium II 650 Mhz

512Mb RAM

gcc 3.2.2

libstdc++ 3.2.2

qt 3.1.1