[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: duali debian packages ( was about duali-data )

On Tue, Jul 01, 2003 at 12:41:31AM +0300, Mohammed Sameer wrote:
> I'm really sorry for being late,
> Maybe i'm not working as i've used to :-(
> I've completed the packages but i didn't test them well as i'm using a 
> pure woody system and duali require python2.2-bsddb which is only 
> available in unstable.
> What's next ?

Well.. looks like I'm going to have to write a whole bunch of code to
ensure backward compatibility with versions of python prior to 2.2, as
well as the bsddb1 (currently using bsddb3).

I guess we can't really package it without those additions. Sounds
reasonable enough to make a 0.1.1 then. I'll make those additions, but I
really am not sure of the implications in terms of unicode support.
Python's unicode support was "okay" in 2.1.. but nice by 2.2. This may
(must check first) effect the multiple encodings support.

Debian woody does have a python2.2 pkg. I am not sure about the pybsddb
pkg (http://pybsddb.sourceforge.net).

We can wait till I hack up a ver 0.1.1 with backward compatibility, or
pkg this and do it again with better compatibility.

Your call (since you're doing the work).

Mohammed Elzubeir