[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: I'm almost ready!

Once upon a time Yousef Raffa wrote @ 09 Mar 2003 21:15:27 +0300

> Hi guys,
> I successfully logged into Arabeyes.org, updated my profile as requested
> by Mr. kuru. and downloaded the /translate/gnome CVS files.
> Please let me know what sort of files shall I translate.
> One more issue needs to be solved on my part is the availability of the
> ARABIC fonts!!!!! somehow, I don't see my Arabic fonts in my
> applications, I believe Mr. kuru tried to help me on IRC but we couldn't
> get it done, and so did Phactorial!! I actually did the same things on
> same OS (but updated kernel) on a different machine (my laptop) and it
> worked perfectly!!!!!
> This is what I did:
> copied the Arabic TTF fonts to the directory of
> /usr/X11R6/lib/X11/fonts/TTF
> ttmkfdir > fonts.dir
> ttmkfdir > fonts.scale
> xset fp+ /usr/X11R6/lib/X11/fonts/TTF
> xset fp rehash
> I opened gedit and checked for Arabic fonts but it wasn't there!. So I
> thought of restarting my xfs server.
> /etc/init.d/xfs restart
> restarted successfully, opened gedit, and still no Arabic fonts.
> I thought maybe I had to restart my X session, so I logged out, logged
> back in and still there were no Arabic fonts available except that I can
> see them in mozilla when I go to:
> Edit>Preferences>Appearance>Fonts
> Later on, Phactorial suggested adding the FONTPATH to the
> /etc/X11/XF86config file. So I added my font path but it didn't get me
> any further.
> anyhow, I checked the Arabeyes Docs section on Arabic Linux HOWTO. I
> went straight to the section where it says:
> To find out what fonts you have installed in your system, do:
> xlsfonts | more
> The Arabic fonts were there, but I can't use them in gedit for example
> or any other software! except mozilla of course.
> I wish someone can lead me to a simple solution this time and I would
> like to have this chance to thank all those who tried to help me solve
> my issue, thank you very much guys, specially kuru, phactorial and
> whomever I forgotten, as I really forget very frequently ;)
> sorry for my wrong writing!.
> Liquid Crystal
which distro ?
if redhat 8.9 try adding the path to /etc/fonts/fonts.conf

-- Katoob Main Developer
Linux registered user # 224950
ICQ # 58475622
FIRST  make  it  run, THEN make it run fast "Brian Kernighan".

Attachment: pgp00008.pgp
Description: PGP signature